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To perform the labs referenced in this book, please download and install the necessary files (refer to 
your purchase receipt for the download link), navigate to the appropriate lab in the lab menu in the 
Boson NetSim, and load the lab; all labs should work in NetSim 9 or later. To learn more about the 
Boson NetSim or to purchase and download the software, please visit www.boson.com/netsim. 
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affiliates, and/or publishers.
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Boson NetSim Overview
The Boson NetSim® Network Simulator®, which includes the Boson Router Simulator®, is unique compared 
to all others on the market because of the functionality it supports and its features. NetSim utilizes Boson’s 
proprietary Network Simulator, Router Simulator®, and EROUTER® software technologies, along with 
the Boson Virtual Packet Technology® engine, to create individual packets. These packets are routed and 
switched through the simulated network, allowing NetSim to build an appropriate virtual routing table and 
simulate true networking. Other simulation products on the market do not support this level of functionality.

NetSim is a Windows®-based product that simulates a wide variety of Cisco® routers, including the 2500 
series, 2600 series, 2800 series, and 3600 series routers, as well as the Cisco Catalyst 1900 series, 2900 
series, and 3500 series switches. NetSim supports multiple routing protocols, including RIP, IGRP, EIGRP, 
BGP, and OSPF. It supports different LAN/WAN protocols, including PPP/CHAP, ISDN, and Frame Relay. 
The labs in NetSim require only the devices and functionality included with NetSim—they do not require 
access to any external router or switch hardware. NetSim supports many, but not all, of the IOS commands 
available on a physical router or switch. All the commands referenced in the available labs are supported 
by NetSim. The labs included in this book have been selected as companions to the Boson Curriculum. 
However, you can perform any labs that are unlocked for additional practice. 

Achieving Cisco CCENT®, CCNA®, or CCNP® certification is the goal of many people who use this 
product. The Boson NetSim covers not only the SWITCH, TSHOOT, and ROUTE certifications but also 
the ICND1, ICND2, and CCNA certifications, among others. The included labs guide you through the 
configuration of routers, switches, and workstations in a variety of scenarios. Installed labs are made 
available (unlocked) depending on the activation key used to activate the product. All labs are downloaded 
and kept up to date after installation regardless of the activation key used. 

Activation keys unlock labs and increase the number of available commands. Beginning with the Demo 
version of NetSim, the command set is limited to those necessary to perform the steps in the lab. For 
example, if you start your studies with a CCENT activation key, you will have the command set and labs 
available that are necessary to study for that exam. When you are ready to study for either the CCNA or 
CCNP exam, you will need to purchase a new activation key and then activate with the new CCNA or CCNP 
activation key; then, more labs and a larger command set become available. 

A small lock icon ( ) is displayed next to unavailable labs. Higher-level activation keys allow you to work 
through all labs unlocked by lower-level activation keys. All labs included with NetSim are unlocked when a 
CCNP-level activation key is used; courseware labs are unlocked with the appropriate activation key.

After you load and complete an unlocked lab, you can use the grading function in NetSim to grade the lab 
so that you can determine whether you completed it correctly (click Lab > Grade Lab). As you progress 
through the labs, you will master the skills needed to pass the simulation questions in the Cisco certification 
exams. NetSim has the ability to guide and grade, and using it for practice can actually be more helpful than 
using real routers and switches. NetSim allows you to gain experience without requiring you to purchase 
expensive equipment.

The Boson NetSim can be used for additional purposes other than only working through labs. The included 
full version of the NetMap tool allows you to practice designing and planning a network. This tool’s 
functionality goes beyond that of most tools because, once you have created a network topology, you can 
actually create the router configurations that are going to be used, save those configurations, and practice 
using them on simulated devices.
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Routing protocol implementation is one of the more challenging tasks you may encounter. Troubleshooting 
a production network can be a frustrating experience. Fortunately, you can create a virtual copy of your 
network topology by using the Boson NetMap and troubleshoot the problems without interfering with your 
production network. Although you can use NetSim as an aid in troubleshooting, you should not rely only on 
NetSim to make decisions about a production network, because NetSim is not designed to test real networks. 
Instead, it is a tool that you can use to study for Cisco certification.

In summary, Boson NetSim is a flexible and powerful product that can help you become certified and, 
in some cases, can be used to create a simulation of the topology of your corporate network and help you 
practice troubleshooting without using devices on the production network.

Using NetSim to Prepare for Your Certification
By incorporating NetSim as part of your process of achieving a Cisco certification, you can learn and master 
the skills necessary to help you successfully complete your certification track. The purpose of NetSim is to 
help you with the practical, hands-on portion of your education and to ensure that you not only understand 
the concepts of routing but can actually configure and implement routing on Cisco devices.

Mastering Cisco networking involves two fundamental tasks: 

Learn the theory of routers and switches.
Gain the hands-on experience of implementing that theory by configuring the devices in a network and 
testing them in a lab.

Self-studying for a Cisco certification can be a daunting task. The amount of information a CCNA candidate 
is required to know and the skills that candidate is required to possess are quite extensive. To begin learning 
the theory of configuring a network, you can find a good reference book or listen to an instructor. But 
a reference book might not be enough. The book will not give you the practical, hands-on experience of 
routing and switching that you can learn from NetSim—experience that will help you build on the theoretical 
knowledge you learned from the reference book.

Real equipment gives you the ability to practice on actual routers and switches, but it also is a very costly 
way to practice and leaves a lot of room for error. The Boson NetSim, on the other hand, is an excellent tool 
to help you prepare for the CCNA (www.boson.com/certification/CCNA) and CCNP  
(www.boson.com/certification/CCNP) exams. NetSim simulates the behavior of a network and does not 
just return preprogrammed responses to expected command inputs. It allows you to create virtual packets 
and virtual frames that will be routed and switched through the simulated network. Aside from physically 
plugging in the cables and listening to the fan noise, your experience with the simulated network will be 
much the same as your experience with a fully functional lab rack without the expense of the hardware. 
NetSim will enable you to practice various configurations and master helpful skills.

Once you feel you have mastered the theory and the practical labs, you can test your knowledge by using the 
Boson ExSim-Max practice exam products available at the ExSim-Max home page  
(www.boson.com/exsim-max-practice-exams). Boson ExSim-Max practice exam products can include 
complex multiple-choice questions, drag-and-drop questions, Boson NetSimX simulation questions, and 
trouble tickets that simulate the questions you will see on the live exam.

1.
2.

www.boson.com/certification/CCNA
www.boson.com/certification/CCNP
www.boson.com/exsim-max-practice-exams
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The Boson NetSim Network Simulator is the most comprehensive product on the market for learning how to 
configure a Cisco router. The Boson NetSim will not only help you become certified, it will actually help you 
learn and understand how to configure routers, switches, and networks.

For more information on how to use NetSim, please read the NetSim User Manual by clicking Help > Users 
Manual from within NetSim or by downloading the User Manual from the following link:

http://www.boson.com/Files/Support/NetSim-10-User-Manual.pdf

Using NetSim at Home – Single User
The following steps are for installation and activation for a single user license and should not be performed 
on a classroom workstation.

Downloading and Installing NetSim
You can download NetSim from the Boson.com downloads page (account required): 

http://www.boson.com/download

You must have a Boson account to download the NetSim Demo. To create a free account, visit the Boson 
Online Account page (https://www.boson.com/account/default.aspx) and enter a valid e-mail address to begin 
creating an account.

You should download the NetSim installer to your computer before beginning the installation. It is 
recommended that you disable antivirus and firewall software while installing and activating NetSim and 
then reactivate when the installation is complete. Double-click the downloaded installation file to begin the 
installation, and perform the steps described in the prompts during installation.

Activating NetSim – Single User
When you first open NetSim, you will be presented with a Product Activation dialog box. Enter your e-mail 
address and password, and then click Next. On the next screen, select whether you want to activate NetSim 
in Online Mode (recommended method) or Offline Mode. Click Next. Then type the activation key; this 
information should be in the purchase receipt you received via e-mail, or you can find the receipt online on 
your Boson Online Account page (https://www.boson.com/account/default.aspx). If you are a student, you 
might receive this information from your learning institution or your instructor. You must have an active 
Internet connection in order to activate the full version of NetSim.

After a successful activation, the lab packs will be updated and NetSim will be ready for you to use. Installed 
labs are made available (unlocked) depending on the activation key used to activate the product. A small lock 
icon ( ) is displayed next to unavailable labs. To make additional labs available, you will need to purchase a 
new activation key and then reactivate with the new activation key; then, more labs and a larger command set 
become available.

If you have not purchased an activation key for NetSim or if you received an activation key from your 
learning institution, you will not be able to activate the full version of NetSim on your personal computer. 
However, you can choose to continue in Demo mode. When you are running the Demo mode, only the demo 
lab and a limited set of commands are functional. To purchase the full version of NetSim, visit the About 
NetSim page (www.boson.com/support/netsim-support-topics) of the Boson website.

http://www.boson.com/Files/Support/NetSim-10-User-Manual.pdf
http://www.boson.com/download
https://www.boson.com/account/default.aspx
https://www.boson.com/account/default.aspx
www.boson.com/support/netsim-support-topics
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Loading a Lab
You can open NetSim from the shortcut installed during the download or from the Start menu by clicking 
Boson Software > Boson NetSim > Boson NetSim. If you are a student using NetSim at a learning 
institution, you should launch NetSim from the Start menu by clicking Boson Software > Boson NetSim > 
Boson NetSim LS Client. This will enable you to configure NetSim to authenticate with the Boson NetSim 
License Server.

1.	 You can begin a preloaded Boson NetSim lab by performing one of the following tasks:
	 •	 On the navigation pane, click Labs; then, on the Standard tab of the Labs panel, double-click the lab  

	 you want to open.
	 •	 Click to highlight a lab on the Labs pane, then click Lab > Load lab.
	 •	 Select a lab from the list of Recent Labs or Saved Labs on the Home pane.
2.	 After you have loaded a lab, click the Lab Instructions tab and read through the lab instructions.
3.	 From the Devices drop-down menu on the Consoles section, select the device(s) that you need to 

configure in order to complete the lab and follow the steps in the lab. You can also select the device you 
want to configure by clicking the NetMap tab, right-clicking the device, and selecting Configure in 
Simulator.

4.	 When you have completed the lab, click Lab > Grade Lab to ensure that you have completed it 
successfully.

5.	 You can choose to save your single device configuration or multiple device configurations by selecting 
the appropriate option in the File menu. 

You might also be instructed to open labs from a custom lab pack. If any custom labs are available, they will 
be on the Custom tab of the Labs pane. To open a custom lab, double-click the lab you want to load.

Accessing NetSim in the Classroom – Boson LS Client
If you are using NetSim in the classroom, it should already be installed on your classroom workstation. You 
should perform the following steps to configure NetSim to access the NetSim License Server.

As a student using NetSim at a learning institution, you should launch NetSim from the Start menu by 
clicking Boson Software > Boson NetSim > Boson NetSim LS Client. This will enable you to configure 
NetSim to authenticate with the Boson NetSim License Server.

Configuring NetSim to Authenticate with the Boson NetSim License Server
Note: Prior to using the Boson NetSim Client, you might need to associate your Boson.com account 
information with Boson NetSim. If you receive an activation key from your learning institution, activate 
Boson NetSim on your personal computer after creating a Boson.com account. Your network administrator/
instructor can then add you as an authorized user to the license server application. You may need to provide 
your learning institution with the e-mail address associated with your Boson.com account. You should not 
give your Boson.com account password to your instructor or learning institution. Your instructor will assign 
you a password that he or she has configured on the License Server, which you will need for step 3. 

1.	 Run the Boson NetSim LS Client by clicking Start > All Programs > Boson Software > Boson  
NetSim > Boson NetSim LS Client.
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2.	 In the Boson NetSim - License Agreement dialog box, select Yes to agree to the Authorized User 
Agreement. If you do not agree to the Authorized User Agreement, you will not be able to use the Boson 
NetSim client.

3.	 Your instructor will provide you with the settings you need to enter in the Boson NetSim Client dialog 
box. Enter the IP address (or computer name if the client computer and the license server are on a 
Windows-based network) and the port number of the computer running the NetSim License Server 
software. Enter the user name/password combination for authentication to the server. The user name will 
be the login information you used to establish an account with Boson.com, or the user name provided by 
your instructor. Enter the password assigned to you by your network administrator/instructor.

	

4.	 Select either CCNA or CCNP from the Version drop-down list; the version you select must match the 
version that is the current license type configured on the NetSim License Server.

	

5.	 Click Connect.
6.	 If a license is available on the license server, the Continue button will be enabled. Click the Continue 

button to start using the Boson NetSim.

For additional information on using Boson NetSim, please consult the Boson NetSim User Manual on Boson.
com or click Help > Users Manual.
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Loading a Lab
1.	 You can begin a preloaded Boson NetSim lab by performing one of the following tasks:
	 •	 Expand the Labs panel; then, on the Standard tab of the Labs panel, double-click the lab you want  

	 to open.
	 •	 Click to highlight a lab, then click Lab > Load Lab.
	 •	 Select a lab from the list of Recent Labs or Saved Labs on the Home pane.
2.	 After you have loaded a lab, click the Lab Instructions tab and read through the lab instructions.
3.	 From the Devices drop-down menu on the Consoles section, select the device(s) that you need to 

configure in order to complete the lab and follow the steps in the lab. You can also select the device you 
want to configure by clicking the NetMap tab, right-clicking the device, and selecting Configure in 
Simulator.

4.	 When you have completed the lab, click Lab > Grade Lab to ensure that you have completed it 
successfully.

5.	 You can choose to save your single device configuration or multiple device configurations by selecting 
the appropriate option in the File menu.

You might also be instructed to open labs from a custom lab pack. If any custom labs are available, they will 
be on the Custom tab of the Labs pane. To open a custom lab, double-click the lab you want to load.
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Lab 3.1 – Subnet Calculation
Objective
This lab corresponds to ICND1 Module 3: Network Addressing, of Boson’s CCNA Curriculum. In this lab, 
you can practice calculating network, broadcast, and host addresses.

Lab Tasks
Use the IP address and subnet mask in each table to find the correct network address, first host address, last 
host address, and broadcast address. The answers to these problems are on the following pages. You can use 
the space near each IP address block to perform your calculations.

1.

192.168.55.56/29

Network

First Host

Last Host

Broadcast

2.

192.168.10.123/30

Network

First Host

Last Host

Broadcast
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3.

192.168.5.78/27

Network

First Host

Last Host

Broadcast

4.

192.168.15.137/28

Network

First Host

Last Host

Broadcast

5.

192.168.67.158/24

Network

First Host

Last Host

Broadcast
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6.

192.168.45.101/25

Network

First Host

Last Host

Broadcast

7.

192.168.78.91/26

Network

First Host

Last Host

Broadcast

8.

172.16.22.53/23

Network

First Host

Last Host

Broadcast
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9.

172.16.96.25/20

Network

First Host

Last Host

Broadcast

10.

172.16.87.56/22

Network

First Host

Last Host

Broadcast

11.

172.16.33.98/21

Network

First Host

Last Host

Broadcast
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12.

10.1.56.32/16

Network

First Host

Last Host

Broadcast

13.

15.16.17.18/28

Network

First Host

Last Host

Broadcast

14.

83.18.38.56/26

Network

First Host

Last Host

Broadcast
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15.

172.18.43.15/22

Network

First Host

Last Host

Broadcast

16.

192.168.12.146/30

Network

First Host

Last Host

Broadcast
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Lab Solutions
Subnet Calculation Answers
You can use the Boson subnetting calculator found at www.boson.com/FreeUtilities and the TCP/IP 
subnetting worksheet found at www.boson.com/promo/guides/TCPIP-SUB.pdf to verify your answers. 

1.

192.168.55.56/29

Network

192.168.55.56

First Host

192.168.55.57

Last Host

192.168.55.62

Broadcast

168.168.55.63

2.

192.168.10.123/30

Network

192.168.10.120

First Host

192.168.10.121

Last Host

192.168.10.122

Broadcast

192.168.10.123

3.

192.168.5.78/27

Network

192.168.5.64

First Host

192.168.5.65

Last Host

192.168.5.94

Broadcast

192.168.5.95

4.

192.168.15.137/28

Network

192.168.15.128

First Host

192.168.15.129

Last Host

192.168.15.142

Broadcast

192.168.15.143

5.

192.168.67.158/24

Network

192.168.67.0

First Host

192.168.67.1

Last Host

192.168.67.254

Broadcast

192.168.67.255

6.

192.168.45.101/25

Network

192.168.45.0

First Host

192.168.45.1

Last Host

192.168.45.126

Broadcast

192.168.45.127

www.boson.com/FreeUtilities
www.boson.com/promo/guides/TCPIP-SUB.pdf
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7.

192.168.78.91/26

Network

192.168.78.64

First Host

192.168.78.65

Last Host

192.168.78.126

Broadcast

192.168.78.127

8.

172.16.22.53/23

Network

172.16.22.0

First Host

172.16.22.1

Last Host

172.16.23.254

Broadcast

172.16.23.255

9.

172.16.96.25/20

Network

172.16.96.0

First Host

172.16.96.1

Last Host

172.16.111.254

Broadcast

172.16.111.255

10.

172.16.87.56/22

Network

172.16.84.0

First Host

172.16.84.1

Last Host

172.16.87.254

Broadcast

172.16.87.255

11.

172.16.33.98/21

Network

172.16.32.0

First Host

172.16.32.1

Last Host

172.16.39.254

Broadcast

172.16.39.255

12.

10.1.56.32/16

Network

10.1.0.0

First Host

10.1.0.1

Last Host

10.1.255.254

Broadcast

10.1.255.255
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13.

15.16.17.18/28

Network

15.16.17.16

First Host

15.16.17.17

Last Host

15.16.17.30

Broadcast

15.16.17.31

14.

83.18.38.56/26

Network

83.18.38.0

First Host

83.18.38.1

Last Host

83.18.38.62

Broadcast

83.18.38.63

15.

172.18.43.15/22

Network

172.18.40.0

First Host

172.18.40.1

Last Host

172.18.43.254

Broadcast

172.18.43.255

16.

192.168.12.146/30

Network

192.168.12.144

First Host

192.168.12.145

Last Host

192.168.12.146

Broadcast

192.168.12.147
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Module 5
Device Management

Module 5: Device Management

Lab 5.1 – Router Configuration
Lab 5.2 – TFTP and Router Configuration
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Lab 5.1 – Router Configuration
To perform this lab in the Boson NetSim, navigate to the appropriate lab in the lab menu in NetSim and load 
the lab. You can then perform the tasks below.

Objective
This lab corresponds to ICND1 Module 5: Device Management, of Boson’s CCNA Curriculum. In this lab, 
you will learn basic help commands available on routers, how to configure IP addresses on routers, and how 
to configure and use Telnet. A password of cisco has been configured on Router2.

Lab Topology
The topology diagram below represents the NetMap in the Simulator:

S0/0/0

Router1 Router3

Router2 S0/0/1

S0/0/0

S0/0/0

The commands you will need to perform the tasks in this lab, along with their syntax and descriptions, are 
shown in the Command Summary table below:

Command Summary
Command Description

clock rate clock-rate sets the clock rate for a data communications equipment 
(DCE) interface

configure terminal enters global configuration mode from privileged EXEC 
mode

enable enters privileged EXEC mode
end ends and exits configuration mode
exit exits one level in the menu structure
hostname host-name sets the device name
interface type number changes from global configuration mode to interface 

configuration mode
ip address ip-address subnet-mask assigns an IP address to an interface
line console 0 accesses console line configuration mode
line vty 0 4 enters configuration mode for virtual terminal (Telnet) 

lines
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Command Description
login enables password checking
no shutdown enables an interface
password password specifies the password that is required for a user to log in
ping ip-address sends an Internet Control Message Protocol (ICMP) echo 

request to the specified address
show running-config displays the active configuration file
show cdp neighbors detail displays directly connected neighbor devices and their 

device types, interface names, and IP addresses
telnet host starts the terminal emulation program from a PC, router, 

or switch; permits you to access devices remotely over the 
network

The IP addresses and subnet masks used in this lab are shown in the table below:

IP Addresses
Device Interface IP Address Subnet Mask

Router1 Serial 0/0/0 34.25.67.1 255.255.255.0
Router2 Serial 0/0/0

Serial 0/0/1
34.25.67.2
10.10.10.2

255.255.255.0
255.255.255.0

Router3 Serial 0/0/0 10.10.10.1 255.255.255.0

Lab Tasks
Task 1: Learn the Basic User Interface
1.	 Connect to the console of Router1. 

2.	 At the user EXEC mode prompt, type a question mark (?). This will enable you to view a list of 
commands that can be issued from the user EXEC mode. At the ––MORE–– prompt, press the Spacebar 
to view the next page of information. 

3.	 Issue the enable command to enter privileged EXEC mode.

4.	 At the privileged EXEC mode prompt, type a question mark (?). This will enable you to view a list 
of commands that can be issued from the privileged EXEC mode. At the ––MORE–– prompt, press the 
Spacebar to view the next page of information. 

5.	 At the privileged EXEC mode prompt, type show ? to see all the available show commands. In 
addition to showing available commands that can be issued at the user EXEC and privileged EXEC 
prompt, the question mark offers additional help.
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Task 2: Configure a Host Name and IP Address on Router1
Perform the steps in this task on Router1.
1.	 Enter the command necessary to access global configuration mode.

2.	 From global configuration mode, configure a host name of Router1.

3.	 Configure the appropriate IP address on the Serial 0/0/0 interface; refer to the IP Addresses table. 
Enable the Serial 0/0/0 interface.

Task 3: Configure and Secure the Router for Console and Remote Connections
1.	 You can connect to a Cisco device remotely by using a protocol such as Telnet or locally by using 

a console connection. Physical access is necessary to connect to the console connection on a Cisco 
device. Enter the commands necessary to configure a password of cisco for console access on Router1 
and require a user to log in to the console port.

2.	 Test the console password by logging out of the router and then pressing the Enter key. With the 
console password configured, you are required to provide a password before you can access user 
EXEC mode.

3.	 Configure Router1 to allow Telnet remote access using its virtual terminal (vty) lines and require a user 
to log in to enter commands using a Telnet session. Use boson as the password. 

4.	 Cisco devices support remote access via the Telnet or Secure Shell (SSH) protocol. Issue the command 
necessary to allow only Telnet access to Router1.

5.	 IP addressing and the remote access configurations have already been performed on Router2. From 
Router2, what protocol can be used to obtain information about neighboring Cisco devices that are 
directly connected? ___________________________________________________________________

6.	 On Router2, issue the appropriate show command. What IP address is assigned to Router1? _ ________

7.	 Test your configuration by initiating a Telnet session to Router1 from Router2 by using the IP address 
you recorded in the previous step. The password configured on Router2 for remote access is boson.

8.	 End the Telnet session from Router2 to Router1.
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Lab Solutions
Task 1: Learn the Basic User Interface
1.	 You should press Enter to connect to the console of Router1: 

 
Press ENTER to Start! 
Router>

2.	 You are now connected to the console of Router1 and are at the user EXEC mode prompt, and you 
should type ? to view commands that are available from the user EXEC prompt, which is represented 
by the > prompt.  
 
Note: You can view the additional device output one line at a time by pressing Enter or a page at a time 
by pressing the Spacebar. To stop viewing the output before all of it has been displayed, press the Tab 
key. 
 
Router>? 
access-enable      Create a temporary Access-List entry 
access-profile     Apply user-profile to interface 
connect            Open a terminal connection 
disable            Turn off privileged commands 
disconnect         Disconnect an existing network connection 
enable             Turn on privileged commands 
exit               Exit from the EXEC 
help               Description of the interactive help system 
lock               Lock the terminal 
login              Log in as a particular user 
logout             Exit from the EXEC 
mrinfo             Request neighbor and version information from a multicast  
                   router 
mstat              Show statistics after multiple multicast traceroutes 
mtrace             Trace reverse multicast path from destination to source 
name-connection    Name and existing network connection 
pad                Open a X.29 PAD connection 
ping               Send echo messages 
ppp                Start IETF Point-to-Point Protocol (PPP) 
resume             Resume an active network connection 
rlogin             Open an rlogin connection 
show               Show running system information 
slip               Start a Serial-line IP (SLIP) 
systat             Display information about terminal lines 
--MORE–- 
<output omitted>

3.	 You should issue the enable command to enter privileged EXEC mode: 
 
Router>enable 
Router#
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4.	 You should type ? to view commands that are available from the privileged EXEC mode prompt, 
which is represented by the # prompt. Sample output is shown below:  
 
Router#? 
access-template         Create a temporary Access-List entry 
alps                    ALPS exec commands 
archive                 manage archive files 
bfe                     For manual emergency modes setting 
cd                      Change current directory 
clear                   Reset functions 
clock                   Manage the system clock 
configure                Enter configuration mode 
copy                    Copy from one file to another 
debug                   Debugging functions (see also ‘undebug’) 
delete                  Delete a file 
dir                     List files on a filesystem 
disable                  
disconnect              Disconnect an existing network connection 
elog                    Event-logging control commands 
erase                   Erase a filesystem 
exit                     
logout                  Exit from the EXEC 
more                    Display the contents of a file 
mrm                     IP Multicast Routing Monitor Test 
ncia                    Start/Stop NCIA Server 
ping                    Send echo messages 
pwd                     Display current working directory 
--MORE–- 
<output omitted>

5.	 You should type show ? to see all the available show commands. In addition to showing available 
commands that can be issued at the user EXEC and privileged EXEC prompt, the question mark offers 
additional help by showing all the commands available with the initial prefix. Sample output is shown 
below: 
 
Router#show ? 
access-lists            List access lists 
arp                     ARP table 
auto                    Show Automation Template 
bgp                     BGP information 
cdp                     CDP information 
class-map               Show QoS Class-Map 
clns                    CLNS network information 
clock                   Display the system clock 
compress                Show compression statistics 
configuration           Contents of Non-Volatile memory 
controllers             Interface controller status 
crypto                  Encryption module 
debugging               State of each debugging option 
dhcp                    Dynamic Host Configuration Protocol status 
<output omitted>



27© 2016 Boson Software, LLC

ICND1 Lab 5.1 – Router Configuration

Labs powered by

Task 2: Configure a Host Name and IP Address on Router1
1.	 You should issue the configure terminal command to enter global configuration mode: 

 
Router#configure terminal  
Router(config)#

2.	 You should issue the hostname Router1 command to configure the host name on Router1: 
 
Router(config)#hostname Router1  
Router1(config)#

3.	 You should issue the following commands to configure the appropriate IP address and subnet mask on 
the Serial 0/0/0 interface of Router1: 
 
Router1(config)#interface serial 0/0/0 
Router1(config-if)#ip address 34.25.67.1 255.255.255.0 
Router1(config-if)#no shutdown

Task 3: Configure and Secure the Router for Console and Remote Connections
1.	 On Router1, you should issue the following commands to configure a password of cisco for the console 

connection and enable password protection on the console connection: 
 
Router1(config-if)#exit  
Router1(config)#line console 0 
Router1(config-line)#password cisco  
Router1(config-line)#login

2.	 Test the console password by entering the following commands: 
 
Router1(config-line)#end 
Router1#disable 
Router1>exit 
Password:cisco 
Router1>

3.	 You should issue the following commands on Router1 to enable remote access via the vty lines and 
configure a password of boson: 
 
Router1>enable  
Router1#configure terminal  
Router1(config)#line vty 0 4 
Router1(config-line)#login 
Router1(config-line)#password boson 
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4.	 You should issue the following command to allow only Telnet access to Router1: 
 
Router1(config-line)#transport input telnet

5.	 You should issue the show cdp neighbors detail command on Router2 to obtain the IP address of 
Router1. When enabled, the Cisco Discovery Protocol (CDP) can be used to obtain information about 
directly connected neighboring Cisco devices. Sample output is shown below: 
 
Password:cisco 
Router2>enable 
Router2#show cdp neighbors detail  
<output omitted> 
------------------------- 
Device ID: Router1 
Entry address(es): 
  IP address: 34.25.67.1 
Platform: Boson 2811 , Capabilities: Router 
Interface: Ser0/0/0, Port ID (outgoing port): Ser 0/0/0 
Holdtime:  162 sec 
 
Version : 
Boson Operating System Software 
Software, Version 12.3(16), RELEASE SOFTWARE (fc2) 
Copyright (c) 1986-2011 by Systems, Inc. 
Compiled Fri 02-Mar-09 17:34 by dchih

6.	 The IP address assigned to Router1 is 34.25.67.1.

7.	 On Router2, you should issue the following commands to initiate a Telnet session to Router1: 
 
Router2#telnet 34.25.67.1 
Trying 34.25.67.1 ... Open 
Password:boson 
Router1>

8.	 The following command will end the Telnet session: 
 
Router1>exit 
Router2#
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Sample Configuration Script
Router1

Router1#show running-config 
Building configuration...
Current configuration : 773 bytes
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
ip subnet-zero
!
ip cef
no ip domain-lookup
!
interface Serial0/0/0
 ip address 34.25.67.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
line con 0
 login
 password cisco
line aux 0
line vty 0 4
 login 
 password boson
 transport input telnet
!
no scheduler allocate
end



Certification Candidates

Boson Software’s ExSim-Max practice exams are designed to simulate the complete exam experience. 
These practice exams have been written by in-house authors who have over 30 years combined 
experience writing practice exams. ExSim-Max is designed to simulate the live exam, including topics 
covered, question types, question difficulty, and time allowed, so you know what to expect. To learn 
more about ExSim-Max practice exams, please visit www.boson.com/exsim-max-practice-exams or 
contact Boson Software.

Organizational and Volume Customers

Boson Software’s outstanding IT training tools serve the skill development needs of organizations such 
as colleges, technical training educators, corporations, and governmental agencies. If your organization 
would like to inquire about volume opportunities and discounts, please contact Boson Software at 
orgsales@boson.com.
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E-Mail:		 support@boson.com
Phone:		877 -333-EXAM (3926)
		  615-889-0121
Fax:		  615-889-0122
Address:	 25 Century Blvd., Ste. 500
		  Nashville, TN 37214
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